Exercícios de Algoritmos Resolvidos

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Exercícios de Algoritmos Resolvidos

Mensagem por jwdiniz em Qua 3 Ago - 16:07

Código:

algoritmo "semnome"
// Função :
// Autor :
// Data : 28/07/2011
// Seção de Declarações
var
numeroDependente: inteiro
nome, flagSalarioLiquido : caracter
rendaMensal, rendamensalDesconto: real
rendaBaseIRPF, inss,irpf, descontoDependente, valorDependente, salarioLiquido: real
inicio
// Seção de Comandos
        repita
        numeroDependente <- 0
        nome <- ""
        rendaMensal <- 0
        rendaMensalDesconto <- 0
        rendaBaseIRPF <- 0
        inss <- 0
        irpf <- 0
        descontoDependente <- 90
        valorDependente <- 0
        salarioLiquido <- 0
       
        escreval (" Informe o nome do funcionário: ")
        leia (nome)
        escreval (" Informe a renda mensal: ")
        leia (rendaMensal)
        escreval (" Informe o numero de dependentes: ")
        leia (numeroDependente)
        valorDependente <- numeroDependente * descontoDependente
        rendaMensalDesconto <- rendaMensal - valorDependente
       
        se (rendaMensalDesconto<= 287.27) entao
            inss<- rendaMensalDesconto * 8/100
        senao
            se ((rendaMensalDesconto > 287.27) e (rendaMensalDesconto <= 478.78)) entao
              inss <- rendaMensalDesconto * 9/100
            senao
              se ((rendaMensalDesconto > 478.78) e (rendaMensalDesconto <= 957.56)) entao
                  inss <- rendaMensal * 11/100
              senao
                  inss <- 105.33
              fimse
            fimse
        fimse
       
       
        salarioLiquido <- rendaMensal - valorDependente - inss - irpf
       
        escreval ("")
        escreval (" Funcionário                                : ", nome)
        escreval (" Renda mensal                                : ", rendaMensal :9:2)
        escreval (" Número de Dependentes                      : ", numeroDependente)
        escreval (" Desconto dos Dependentes                    : ", valorDependente)
        escreval (" Renda mensal                                : ", rendaMensal :9:2)
        escreval (" Renda mensal c/ desc. Dependentes          : ", rendaMensalDesconto :9:2)
        escreval (" INSS                                        : ", inss :9:2)
        escreval (" Renda Líquida                              : ", rendaBaseIRPF :9:2)
        escreval (" Imposto de Renda                            : ", irpf :9:2)
        escreval ("")
        escreval ("                  SALÁRIO LIQUIDO              ", salarioLiquido :9:2)
        escreval ("")
       
        escreval (" Deseja realizar novo cálculo na folha de pagamento? (S/N): ")

        leia (flagSalarioLiquido)
          limpatela
      ate flagSalarioLiquido = "N"

       
       
       
       
       
       
       
fimalgoritmo
[hr]
algoritmo "ex15"
// Função : Faça um algoritmo que receba um número e diga se este número está no intervalo entre 100 e 200.
// Autor :
// Data : 1/12/2010
// Seção de Declarações
var
numero: inteiro

inicio
// Seção de Comandos
escreva("Digite um número: ")
leia(numero)
se numero >= 100 entao
  se numero <= 200 entao
      escreval("O número está no intervalo entre 100 e 200")
  senao
        escreval("O número não está no intervalo entre 100 e 200")
  fimse
senao
  escreval("O número não está no intervalo entre 100 e 200")
fimse

fimalgoritmo
[hr]
algoritmo "ex33"
// Função : Escrever um algoritmo que leia três valores inteiros e verifique se eles podem ser os lados de um triângulo. Se
            // forem, informar qual o tipo de triângulo que eles formam: equilátero, isóscele ou escaleno
// Autor :
// Data : 1/12/2010
// Seção de Declarações
var
la, lb, lc, triangulo: inteiro
inicio
// Seção de Comandos
escreva("Digite o lado A do triângulo: ")
leia(la)
escreva("Digite o lado B do triângulo: ")
leia(lb)
escreva("Digite o lado C do triângulo: ")
leia(lc)

se la < (lc+lb) entao
    triangulo <- 1
senao
    se lb < (lc + la) entao
        triangulo <- 1
    senao
        se lc < (lb + la) entao
            triangulo <- 1
        fimse
    fimse
fimse

se triangulo = 1 entao
    se la = lb entao
        se lb = lc entao
            escreval("É um triângulo equilátero!")
        senao
            escreval("É um triângulo isórcele")
        fimse
    senao
        se lb = lc entao
            escreval("É um triângulo isórcele")
        senao
            escreval("É um triângulo escaleno")
        fimse
    fimse
fimse

fimalgoritmo
[hr]
algoritmo "ex21"
// Função : Escrever um algoritmo que leia os dados de N pessoas (nome, sexo, idade e saúde) e informe se está apta ou não
            // para cumprir o serviço militar obrigatório. Informe os totais.
// Autor :
// Data : 1/12/2010
// Seção de Declarações
var
programa, idade, apto: inteiro
nome, sexo, saude, opc: caractere
totApto, total: inteiro
inicio
// Seção de Comandos
programa <- 1
enquanto programa = 1 faca
    limpatela
    apto <- 1
    saude <- "B"
    total <- total + 1
    escreva("Digite o nome: ")
    leia(nome)
    escreva("Digite o sexo (M/F): ")
    leia(sexo)
    escreva("Digite a idade: ")
    leia(idade)
    se idade < 18 entao
        apto <- 0
    fimse
    escreval("Digite o estado de saúde: ")
    escreva("(B) Bom - (R) - Ruim - ")
    leia(saude)
    se saude = "R" entao
        apto <- 0
    senao
        se saude <> "B" entao
            apto <- 0
        fimse
    fimse
    se apto = 1 entao
        totApto <- totApto + 1
    fimse
    escreval("Deseja continuar filtrando (S/N)? ")
    leia(opc)
    se opc = "N" entao
        programa <- 0
    fimse
fimenquanto
limpatela
escreval("Resumo geral: ")
escreval("Foram filtrados: ",total," pessoas")
escreval("Aptos: ",totApto)
escreval("")

fimalgoritmo
[hr]
algoritmo "ex17"
// Função : Ler 80 números e ao final informar quantos número(s) est(á)ão no intervalo entre 10 (inclusive) e 150 (inclusive).
// Autor :
// Data : 1/12/2010
// Seção de Declarações
var
x, num, intervalo: inteiro

inicio
// Seção de Comandos
para x de 1 ate 80 faca
    escreva("Digite um número: ")
    leia(num)
    se num >= 10 entao
        se num <= 150 entao
          intervalo <- intervalo + 1
        fimse
    fimse
fimpara

escreval("Ao total, foram digitados",intervalo,"números no intervalo entre 10 e 150")
 
fimalgoritmo
[hr]
algoritmo "semnome"
// Função :
// Autor :
// Data : 30/06/2011
// Seção de Declarações

var
x : inteiro
i :inteiro
op, num:inteiro
opc : caracter
inicio
// Seção de Comandos
repita
  escrevaL ("")
  escrevaL ("............................... SISTEMA DE TABUADA ............................... ")
  ESCREVAL ("")
  ESCREVAL ("")
  ESCREVAL ("")
  ESCREVAL ("                          ESCOLHA UM OPÇÃO PARA A TABUADA                          ")
  ESCREVAL ("")
  ESCREVAL("")
  ESCREVAL("")
  ESCREVAL (" |===============================================================================|")
  escreval (" |                                  1) ADIÇÃO                                    |")
  escreval (" |                                  2) SUBTRAÇÃO                                |")
  ESCREVAL (" |                                  3) MULTIPLICAÇÃO                            |")
  ESCREVAL (" |                                  4) DIVISÃO                                  |")
  ESCREVAL (" |===============================================================================|")
  ESCREVAL ("")

  escreva ("Escolha uma das opções acima: ")
  leia (op)
  limpatela
caso 1
  se op = 1 entao
      escreva ("Digite a tabuada que deseja ver: ")
      leia(x)
      escreva ("Até quando você deseja que apareça o numero de Adição: ")
      leia (num)

      escreval ( "A tabuada de " ,x, " Adição até: ", num, " é: ")
      para i de 1 ate num faca
        escreval( x , " + ", i, " = ", x+i)

      fimpara
  fimse
caso 2
  se op = 2 entao
      escreva ("Digite a tabuada que deseja ver: ")
      leia(x)
      escreva ("Até quando você deseja que apareça o numero de Subtração: ")
      leia (num)

      escreval ( "a tabuada de " ,x, " subtração até: ", num, " é: ")
      para i de 1 ate num faca
        escreval( x , " - ", i, " = ", x-i)

      fimpara
  fimse
caso 3
  se op = 3 entao
      escreva ("Digite a tabuada que deseja ver: ")
      leia(x)
      escreva ("até quando você deseja que apareça o numero de Multiplicação: ")
      leia (num)

      escreval ( " a tabuada de " ,x, " Multiplicada até: ", num, " é: ")
      para i de 1 ate num faca
        escreval( x , " x ", i, " = ", x*i)

      fimpara
  fimse
  se op = 4 entao
      escreva ("Digite a tabuada que deseja ver: ")
      leia(x)
      escreva ("até quando você deseja que apareça o numero de Divisão: ")
      leia (num)

      escreval ( "a tabuada de " ,x, " Dividida até: ", num, " é: ")
      para i de 1 ate num faca
        escreval( x , " / ", i, " = ", x/i)

      fimpara
  fimse
  escreva ("Deseja continuar calculando? S|N ")
  leia (opc)
  limpatela
ate opc = "n"
ESCREVAL ("")
escreval ("************************ OBRIGADO POR ESCOLHER ESTE SOFTWARE ***************************")
ESCREVAL ("")
fimalgoritmo

[hr]
algoritmo "ex6"
// Função : Ler dois valores para as variáveis A e B, e efetuar as trocas dos valores de forma que a variável A passe a possuir o
            // valor da variável B e a variável B passe a possuir o valor da variável A. Apresentar os valores trocados.
// Autor :
// Data : 30/11/2010
// Seção de Declarações
var
a, b, troca: inteiro

inicio
// Seção de Comandos
escreva("Digite o valor(numérico) da variável A: ")
leia(a)
escreva("Digite o valor(numérico) da variável B: ")
leia(b)
troca <- a
a <- b
b <- troca
limpatela
escreval("===========================")
escreval("O novo valor de A é: ",a)
escreval("O novo valor de B é: ",b)
escreval("===========================")

 
fimalgoritmo
[hr]
algoritmo "ex13"
// Função : Faça um algoritmo que receba um número e mostre uma mensagem caso este número seja maior que 10.
// Autor :
// Data : 1/12/2010
// Seção de Declarações
var
numero: inteiro

inicio
// Seção de Comandos
escreva("Digite um número: ")
leia(numero)
se numero > 10 entao
  escreval("O número é maior que 10")
fimse

fimalgoritmo
[hr]
algoritmo "ex16"
// Função : Escrever um algoritmo que leia o nome e as três notas obtidas por um aluno durante o semestre. Calcular a sua
            // média (aritmética), informar o nome e sua menção aprovado (media >= 7), Reprovado (media <= 5) e Recuperação
            // (media entre 5.1 a 6.9).
// Autor :
// Data : 1/12/2010
// Seção de Declarações
var
nome: caractere
n1, n2, n3, media: real

inicio
// Seção de Comandos
escreval("Sistema de médias")
escreva("Digite a primeira nota: ")
leia(n1)
escreva("Digite a segunda nota: ")
leia(n2)
escreva("Digite a terceria nota: ")
leia(n3)
media <- (n1 + n2 + n3) / 3

se media >= 7 entao
  escreval("Aluno aprovado!")
senao
  se media <= 5 entao
      escreval("Aluno reprovado!")
  senao
      escreval("Aluno em recuperação...")
  fimse
fimse

fimalgoritmo
[hr]
algoritmo "ex29"
// Função : Faça um algoritmo que receba o número do mês e mostre o mês correspondente. Valide mês inválido
// Autor :
// Data : 1/12/2010
// Seção de Declarações
var
mes: inteiro

inicio
// Seção de Comandos
escreval("Digite o número do mês: ")
leia(mes)
escolha mes
caso 1
    escreval("Janeiro")
caso 2
    escreval("Fevereiro")
caso 3
    escreval("Março")
caso 4
    escreval("Abril")
caso 5
    escreval("Maio")
caso 6
    escreval("Junho")
caso 7
    escreval("Julho")
caso 8
    escreval("Agosto")
caso 9
    escreval("Setembro")
caso 10
    escreval("Outubro")
caso 11
    escreval("Novembro")
caso 12
    escreval("Dezembro")
outrocaso
    escreval("Mês inválido!")
fimescolha

fimalgoritmo
[hr]
algoritmo "ex24"
// Função : Faça um algoritmo que receba N números e mostre positivo, negativo ou zero para cada número.
// Autor :
// Data : 1/12/2010
// Seção de Declarações
var
programa, numero: inteiro
opc: caractere

inicio
// Seção de Comandos
programa <- 1
enquanto programa = 1 faca
    limpatela
    escreva("Digite um número: ")
    leia(numero)
    se numero > 0 entao
        escreval("Positivo")
    senao
        se numero = 0 entao
            escreval("O número é igual a 0")
        fimse
        se numero < 0 entao
            escreval("Negativo")
        fimse
    fimse


    escreva("Deseja finalizar? (S/N) ")
    leia(opc)
    se opc = "S" entao
        programa <- 0
    fimse

fimenquanto

fimalgoritmo
[b]

__________________________________________

_____________Programação em Foco____________

_________________Seu Fórum__________________




jwdiniz
Turma 20.911

Mensagens: 8
Reputação: 0
Data de inscrição: 06/04/2011

Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

Permissão deste fórum:
Você não pode responder aos tópicos neste fórum