Exercicios Resolvidos

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Exercicios Resolvidos

Mensagem por jwdiniz em Qua 3 Ago - 15:00

Código:

algoritmo "ex8"
// Função : Elaborar um algoritmo que efetue a apresentação do valor da conversão em real (R$) de um valor lido em dólar
            // (US$). O algoritmo deverá solicitar o valor da cotação do dólar e também a quantidade de dólares disponíveis com o usuário.
// Autor :
// Data : 30/11/2010
// Seção de Declarações
var
rs, us, cotacao, dolaDisponivel: real

inicio
// Seção de Comandos
escreval("========= Cotação do Dólar ==========")
escreva("Qual a cotação atual do dólar? ")
leia(cotacao)
escreva("Quantos dólares você possui? ")
leia(us)
rs <- us/cotacao
limpatela
escreval(us," Dólares equivalem á: ",rs," R$")
 
fimalgoritmo
[hr]
algoritmo "ex12"
// Função : O custo ao consumidor de um carro novo é a soma do custo de fábrica com a percentagem do distribuidor e dos
            // impostos (aplicados, primeiro os impostos sobre o custo de fábrica, e depois a percentagem do distribuidor sobre o
            // resultado). Supondo que a percentagem do distribuidor seja de 28% e os impostos 45%. Escrever um algoritmo que
            // leia o custo de fábrica de um carro e informe o custo ao consumidor do mesmo.
// Autor :
// Data : 1/12/2010
// Seção de Declarações
var
custoFabrica, custoFinal: real

inicio
// Seção de Comandos

escreva("Informe o custo de fábrica do veículo: ")
leia(custoFabrica)
custoFinal <- custoFabrica + (0.28 * custoFabrica) + (0.45 * custoFabrica)
escreval("O custo para o consumidor final é de: ",custoFinal)



fimalgoritmo
[hr]
algoritmo "ex11"
// Função : Faça um algoritmo que receba o preço de custo de um produto e mostre o valor de venda. Sabe-se que o preço de
            // custo receberá um acréscimo de acordo com um percentual informado pelo usuário.
// Autor :
// Data : 1/12/2010
// Seção de Declarações
var
custo, venda, percent: real

inicio
// Seção de Comandos
escreva("Digite o custo do produto: ")
leia(custo)
escreva("Digite o percentual para venda: ")
leia(percent)
percent <- (percent/100) * custo
venda <- custo + percent
escreval("O valor de venda é: ",venda)

fimalgoritmo
[hr]
algoritmo "ex9"
// Função : Faça um algoritmo que receba um valor que foi depositado e exiba o valor com rendimento após um mês.
            // Considere fixo o juro da poupança em 0,70% a. m.
// Autor :
// Data : 1/12/2010
// Seção de Declarações
var
correcao, deposito: real


inicio
// Seção de Comandos
escreval("Sistema de depósito do Banco do Oeste")
escreva("Digite o valor depositado: ")
leia(deposito)
correcao <- 0.07 * deposito
escreva("O rendimento do depósito após um mês é de: ",deposito+correcao)
 
fimalgoritmo
[hr]
algoritmo "ex39"
// Função :
// Autor :
// Data : 1/12/2010
// Seção de Declarações
var
idade, grupo: inteiro
nome, grupoRisco: caractere
inicio
// Seção de Comandos
escreva("Digite o nome: ")
leia(nome)
escreva("Digite a idade: ")
leia(idade)
escreval("Informe o Grupo de risco: ")
escreval("(B)aixo / (M)édio / (A)lto ")
leia(grupoRisco)

se (idade >= 17) e (idade <= 70) entao

se idade <= 20 entao
    escolha grupoRisco
        caso "B"
            grupo <- 1
        caso "M"
            grupo <- 2
        caso "A"
            grupo <- 3
    fimescolha
senao
    se idade <= 24 entao
        escolha grupoRisco
            caso "B"
                grupo <- 2
            caso "M"
                grupo <- 3
            caso "A"
                grupo <- 4
        fimescolha
    senao
        se idade <= 34 entao
            escolha grupoRisco
                caso "B"
                    grupo <- 3
                caso "M"
                    grupo <- 4
                caso "A"
                    grupo <- 5
            fimescolha
        senao
            se idade <= 64 entao
                escolha grupoRisco
                    caso "B"
                        grupo <- 4
                    caso "M"
                        grupo <- 5
                    caso "A"
                        grupo <- 6
                fimescolha
            senao
                escolha grupoRisco
                    caso "B"
                        grupo <- 2
                    caso "M"
                        grupo <- 3
                    caso "A"
                        grupo <- 4
                fimescolha
            fimse
        fimse
    fimse
fimse

senao
    escreval("Idade fora da cobertura!")
fimse

escreval("Nome: ",nome)
escreval("Idade: ",idade)
escreval("Categoria: ",grupo)

fimalgoritmo


__________________________________________

_____________Programação em Foco____________

_________________Seu Fórum__________________




jwdiniz
Turma 20.911

Mensagens : 8
Reputação : 0
Data de inscrição : 06/04/2011

Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum