Algoritmo visualG

 :: Duvidas :: Duvidas

Ver o tópico anterior Ver o tópico seguinte Ir em baixo

Algoritmo visualG

Mensagem por felipesilvaa em Sab 16 Fev - 8:49

--UM ALGORITMO QUE LEIA UM NUMERO E IMPRIMA SE FOR PAR OU IMPAR--
estou tentando dessa maneira, mas nao esta funcionando, por favor me ajudem. Very Happy

var
x:inteiro
w:real
inicio
// Seção de Comandos
leia (w)
x<-w%2
se (x*2<-w) entao
escreva (par)
se (x*2<>w) entao
escreva (impar)
fimse

felipesilvaa
Turma 20.911

Mensagens : 1
Reputação : 1
Data de inscrição : 16/02/2013

Voltar ao Topo Ir em baixo

Re: Algoritmo visualG

Mensagem por Bruno Cavalcante em Ter 5 Mar - 22:53

MOD é um operador matemático q retorna o resto da divisão. E ele é um operador de numeros inteiros, ou seja, a variavel numero tem q ser declarada com inteiro.

Ex: 827 mod 2 = 1, 160 mod 2 = 0.

Código:

var
numero: inteiro

inicio

escreva ("Digite um numero: ")

leia (numero)

se (numero mod 2 = 0) entao

escreva (numero," É par")

senao

escreva (numero," É impar")

fimse

fimalgoritomo

__________________________________________

_____________Programação em Foco____________

_________________Seu Fórum__________________


Bruno Cavalcante
Acesse: www.gearsolucao.com.br
avatar
Bruno Cavalcante
Turma 20.911

Mensagens : 89
Reputação : -1
Data de inscrição : 30/03/2011
Localização : DF

http://www.kavalcanty.blogspot.com/

Voltar ao Topo Ir em baixo

Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo

- Tópicos similares

 :: Duvidas :: Duvidas

 
Permissão deste fórum:
Você não pode responder aos tópicos neste fórum